mirror of
https://github.com/MetaProvide/nextcloud-swarm-plugin.git
synced 2025-02-05 00:59:49 +00:00
3f285c29b0
These files do nothing on systems where Nix and direnv are not installed. They provide development dependencies locally such as PHP, Node.JS and Composer.
17 lines
370 B
Nix
17 lines
370 B
Nix
{ pkgs ? import <nixpkgs> {} }:
|
|
|
|
# SPDX-FileCopyrightText: Copyright (c) 2022, MetaProvide Holding EKF
|
|
# SPDX-License-Identifier: AGPL-3.0-or-later
|
|
|
|
pkgs.mkShell {
|
|
name = "nextcloud";
|
|
nativeBuildInputs = with pkgs; with pkgs.nodePackages;
|
|
[ nodejs-18_x
|
|
php80
|
|
php80Packages.composer
|
|
stylelint
|
|
eslint
|
|
prettier
|
|
webpack-cli
|
|
];
|
|
}
|